Installation

To install:

$ pip install pgcopy

Dependencies

pgcopy requires pytz and the psycopg2 db adapter. pytest is required to run the tests.

Due to technical problems with the psycopg2 binary distributions, versions 2.8 and later have separate packages for binary install. This complicates installation in some situations, as it requires the dev tools to build psycopg2.

If you do not want to build psycopg2 for each installation, the recommended options are:

  • install psycopg2 version 2.7.X before installing pgcopy

  • create a psycopg2 wheel for distribution to production machines

Compatibility

pgcopy is tested with Python versions 2.7, 3.6 – 3.8 and PostgreSQL versions 9.4 – 13

Note

Python 2.7 is no longer supported! Please upgrade to Python 3.